
PIPLATElogger Documentation 
Version 2.0 

4/20/2022 

 

 

 

  



1 TABLE OF CONTENTS 

2 Introduction .................................................................................................................................................................... 3 

3 Requirements .................................................................................................................................................................. 3 

4 Main Screen Elements .................................................................................................................................................... 3 

5 Operation ........................................................................................................................................................................ 4 

5.1 Idle / Setup .............................................................................................................................................................. 4 

5.1.1 Logging Setup .................................................................................................................................................. 4 

5.1.2 Channel Configuration .................................................................................................................................... 6 

5.1.3 Saving and Restoring a Configuration ............................................................................................................. 7 

5.2 Logging Data ............................................................................................................................................................ 7 

5.3 Viewing Logged Data ............................................................................................................................................... 8 

5.3.1 File ................................................................................................................................................................... 8 

5.3.2 Spreadsheet .................................................................................................................................................... 9 

6 Appendix ....................................................................................................................................................................... 12 

6.1 DAQCplate ............................................................................................................................................................. 12 

6.2 DAQC
2
plate ........................................................................................................................................................... 13 

6.3 THERMOplate ........................................................................................................................................................ 14 

6.4 ADCplate ............................................................................................................................................................... 15 

6.5 CURRENTplate ....................................................................................................................................................... 16 

 

  



2 INTRODUCTION 

PIPLATElogger is a utility program that provides an advanced set of tools for logging analog, digital, and temperature 

data with all applicable products from Pi-Plates. The program will work with up to eight each of the following products: 

 DAQCplate 

 DAQC2plate 

 THERMOplate 

 ADCplate 

 CURRENTplate  

To use PIPLATElogger you will need to connect signals to the Analog and Digital inputs of your Pi-Plate. Diagrams 

highlighting the applicable inputs for each Pi-Plate can be found in the Appendix in Section 6. 

PIPLATElogger is designed to run under the X-windows environment on the Raspberry Pi. It is written in Python3 using 

Tkinter and PMW for the graphical user interface. Note that this software is copyright 2022 under version 3 of the GNU 

General Public License. The terms of this license can be found in the Help menu or at this link: 

http://www.gnu.org/licenses/gpl-3.0-standalone.html 

3 REQUIREMENTS 

To use PIPLATElogger you will need the following: 

1) A Raspberry Pi running the Raspberry Pi operating system. While this program should run on any version of the 

RPi, we recommend a version 3 as a minimum. 

2) At least one DAQCplate, DAQC2plate, THERMOplate, ADCplate, or CURRENTplate from Pi-Plates. If you don’t 

have one of these products yet, we invite you to visit our website at https://pi-plates.com and check them out.  

3) Be sure to follow these instructions on how to set up your Raspberry Pi so that it can talk to the Pi-Plate. 

4) Version 9.1 or later of the Pi-Plate Python module. Use “sudo pip install Pi-Plates” if you have a new setup or 

“sudo pip install –U Pi-Plates” to update. 

5) The PMW megawigdets. This module is included in the RPi OS but may not be up to date. PIPLATElogger will 

perform the update automatically. 

6) To fit as much information on the screen, this program runs at a fixed screen size of 1280 x 720. Therefore, it is 

recommended that you use a FHD monitor (1920X1080) for the best experience. If you are using VNCSERVER for 

remote access or headless operation, be sure to set the GEOMETRY option to 1280x720 or greater. 

7) Finally, you will need to download and install PIPLATElogger: 

a. Download the files from our server with: 

sudo wget https://pi-plates.com/downloads/ PIPLATElogger.tar.gz 

b. Then decompress them into your home directory: sudo tar -xzvf PIPLATElogger.tar.gz 

c. Change to the Applications folder with: cd Applications 

d. Open a terminal window and launch the program with: python PIPLATElogger.py 

4 MAIN SCREEN ELEMENTS 

The opening screen of PIPLATElogger is shown in Figure 1 below. There are five primary areas highlighted: 

1) Menubars: this is where you’ll open log files, make and save global setup values, start and stop data logging and 

view your data. All of these options are covered in excruciating detail below. Black menu words trigger drop-

down menus while the colored menu items trigger actions. 

2) Tabs: PIPLATElogger will display a selection tab for each compatible Pi-Plate on the stack. To see the real time 

data from a particular Pi-Plate or to change the selected channels, just click its tab. 



3) Bulk Channel Controls: these two buttons provide a simple means of selecting or deselecting all of the input 

channels on the selected Pi-Plate. 

4) The Channel Select Box / Name / Current Value: these three fields are displayed for each input channel on the 

selected Pi-Plate. 

a. By checking a channel select box, you will be able to monitor its value in real time on the Input Window 

to the right as well as saving the values to a file when a logging session is executed.  

b. The channel name field can be changed to reflect a more descriptive name of your input signal. This 

name will be saved to the log file along with the data. To modify, just click anywhere in the text box to 

edit the default title. 

c. The value shows the current measurement of a channel if it is enabled. 

5) Input Widows: these are mini real time plots of each selected channel. There are approximately 600 points on 

each graph with the newest data appearing on the right and old data sliding off to the left. Different Pi-Plates 

display different data types depending on their capabilities. 

 

Figure 1 

5 OPERATION 

There are three operational modes when using PIPLATElogger: Idle/Setup, Logging, and Viewing Logged Data. 

5.1 IDLE / SETUP 
This is the default mode for PIPLATElogger. It is here where you can select the channels you wish to monitor, change 

their names, create a logging file, test your setup, save and restore configurations 

5.1.1 Logging Setup 

There are three steps for creating a log: 

1) Create or open a log file 

2) Select the sample rate and sample count for your log 

3) START the log 

5.1.1.1 Saving to a File 

To save your log to a local file, click on LOG SETUP->Open New File for Logging: 



 

Figure 2 

A new dialog box will pop up and prompt you to enter the name of your new log file. You can also over write an existing 

log file. Note that all log files are automatically assigned the extension “csv.” Once you have typed in or selected your 

file, click the Save button. If you chose to over write an existing file, the system will ask you to verify this action. When 

you are done with this step, the data from all selected channels will be written to this file while the program is in the 

Logging mode. 



 

Figure 3 

5.1.1.2 Sample Rate / Count 

To change the sample period and count, click LOG SETUP -> Set Logging Parameters on the menu bar. A small menu 

will pop up and you will be to modify these two values. A couple of things to note: 

1) The minimum sample period is dictated by the number of Pi-Plates on your stack. A single DAQC, for example, 

will require 0.2 seconds to capture all eight analog inputs, capture all eight digital inputs, and to update the data 

in the PIPLATElogger window. Two Pi-Plates will force the minimum period to 0.4 seconds. Three will force it to 

0.6 and so on. So, for maximum sample rates, keep your Pi-Plate count low. 

2) The Log Duration is the product of SampleCount X SamplePeriod. So, if you choose a Sample Period of 1 second 

and you set the Sample Count to 1000, then the logging duration shall be 1000 X 1 = 1000 seconds or 16 minutes 

and 40 seconds.  

 

Figure 4 

Note that the Period and Count values are part or the information saved when you choose File -> Save Configuration. 

5.1.2  Channel Configuration 

As mentioned previously, you can choose the channels on each Pi-Plate that you want to monitor simply by clicking the 

checkbox in front of its name as shown in Figure 1. You can also edit the channel names by clicking in the text field and 



changing the default entries to values that are more descriptive of their source. Your data from your selected channels 

and the custom names will be saved to the log file.  

5.1.3 Saving and Restoring a Configuration 

In the File dropdown menu there are commands for Saving and Restoring the Configuration. This is a pretty handy 

feature if you have a setup that you plan to use repeatedly. The configuration will include the selected channels, their 

names, the sample period, the sample count, and your optional streaming parameters. 

Be advised that if you save a configuration and then modify your stack by adding or removing a Pi-Plate, PIPLATElogger 

will show an error message when you try to restore that old configuration. 

5.2 LOGGING DATA 
The moment has finally arrived! You’ve created a log file and set up you sample time and count. Maybe you selected and 

renamed specific channels as well. It’s logging time. Just click the word START on the menu bar and PIPLATElogger will 

start saving data to your selected file. The status of the logger along with the remaining number of samples and time to 

completion will be displayed in the title bar of the program as shown in Figure 5. After the logging has completed, you 

will be alerted with the message shown in Figure 6 

If for any reason you want to halt the logger then simply click on the word STOP in the menu bar. 

A few things to note: 

1) If you stop a log and then click START again, the data previously saved to your log file will be lost. To avoid this, 

choose a new log file before starting another session. 

2) While logging, most menu items are disabled. 

 

Figure 5 



 

Figure 6 

5.3 VIEWING LOGGED DATA 
PIPLATElogger saves data to files in a format called CSV or Comma Separated Variables. This format makes it easy to 

open and edit with a simple text editor. CSV files can also be imported into many popular spreadsheet programs such as 

LibreOffice Calc.  

The program provides two methods to view your log data. To access these, click VIEW on the menu bar. The following 

buttons will then pop up. 

 

Figure 7 

Be advised that some of the VIEW options can cause the logging process to pause. 

5.3.1 File 

Clicking the View Data File and following the prompts allows you to view your raw log data using the text editor that 

comes installed on the Raspberry Pi OS (Figure 8).  

The first line of text is the channel names while the remaining lines are a time stamp followed by the channel data. 

Analog data is represented by numbers in a decimal format (3.82, 2.96, 1.00, etc.) while the digital input data is 

represented by ones and zeros.  



While you can edit this file, be careful not to delete any of the commas separating the data. Otherwise, you won’t be 

able to plot it correctly using the built in Plot program or open it with LibreOffice Calc. 

 

Figure 8 

5.3.2 Spreadsheet  

The final button, Open Data in Spreadsheet passes the selected log file to LibreOffice Calc. When this occurs you will be 

prompted to choose the delimiter that separates the data in your file as shown in Figure 9. Click the checkbox in front of 

“Comma” followed by the OK button. Your log file data will now be presented to you in tabular form. 



 

Figure 9 

By using Calc, not only is your data organized and viewable in a nice clean format but it’s also possible to plot it out using 

a number of different formats. For example, while holding down the shift button, click on columns headers A, B, and C.  

(Figure 10) Then click on the Plot Functions Icon. A preliminary plot will appear but we’re going to create a simple line 

graph. Choose that now and then stick with all of the default values. When finished, you should have a graph similar to 

Figure 11 



Graphing ToolColumn Headers

 

Figure 10 
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6 APPENDIX 

The diagrams below highlight the inputs that can be logged for each Pi-Plate. 

6.1 DAQCPLATE 

 

 

 

Figure 12 



6.2 DAQC2PLATE 
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6.3 THERMOPLATE 
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6.4 ADCPLATE 

 

Figure 15 



6.5 CURRENTPLATE 
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